Abiword dependencies and hal-storage

So, I was installing abiword, and got this when hal-storage, a dependency, was being installed:

checking for GNOME_MOUNT... configure: error: Package requirements (gconf-2.0 gnome-keyring-1 >= 0.4 dbus-glib-1 >= 0.31 hal-storage >= gtk+-2.0 >= 2.8.0) were not met:
Requested 'hal-storage >=' but version of hal-storage is 0.5.8

The problem is that the newest package of hal-storage is 0.5.8. I don’t know why portinstall didn’t fall back to installing it from source, I only did provide the -P argument, not -PP.

Anyway, if you install the port from source, you’ll have 0.5.11, which is sufficient. But that also requires libvolume_id to be updated. So

sudo portinstall libvolume_id hal
sudo portinstall -P abiword

might do the trick.


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )


Connecting to %s

%d bloggers like this: